ImportError: ningún módulo llamado pip

7 minutos de lectura

avatar de usuario
david lu

Sistema operativo: Mac OS X 10.7.5 Versión de Python: 2.7.5

He instalado setuptools 1.0 con ez_setup.py desde https://pypi.python.org/pypi/setuptools
Luego descargo pip.1.4.1 pkg desde https://pypi.python.org/pypi/pip/1.4.1.

Ejecutar (Sudo) python setup.py install en iTerm muestra que

running install
running bdist_egg running egg_info writing requirements to
pip.egg-info/requires.txt writing pip.egg-info/PKG-INFO writing
top-level names to pip.egg-info/top_level.txt writing dependency_links
to pip.egg-info/dependency_links.txt writing entry points to
pip.egg-info/entry_points.txt warning: manifest_maker: standard file
'setup.py' not found

reading manifest file 'pip.egg-info/SOURCES.txt' writing manifest file
'pip.egg-info/SOURCES.txt' installing library code to
build/bdist.macosx-10.6-intel/egg running install_lib warning:
install_lib: 'build/lib' does not exist -- no Python modules to
install

creating build/bdist.macosx-10.6-intel/egg creating
build/bdist.macosx-10.6-intel/egg/EGG-INFO copying
pip.egg-info/PKG-INFO -> build/bdist.macosx-10.6-intel/egg/EGG-INFO
copying pip.egg-info/SOURCES.txt ->
build/bdist.macosx-10.6-intel/egg/EGG-INFO copying
pip.egg-info/dependency_links.txt ->
build/bdist.macosx-10.6-intel/egg/EGG-INFO copying
pip.egg-info/entry_points.txt ->
build/bdist.macosx-10.6-intel/egg/EGG-INFO copying
pip.egg-info/not-zip-safe ->
build/bdist.macosx-10.6-intel/egg/EGG-INFO copying
pip.egg-info/requires.txt ->
build/bdist.macosx-10.6-intel/egg/EGG-INFO copying
pip.egg-info/top_level.txt ->
build/bdist.macosx-10.6-intel/egg/EGG-INFO creating
'dist/pip-1.4.1-py2.7.egg' and adding
'build/bdist.macosx-10.6-intel/egg' to it removing
'build/bdist.macosx-10.6-intel/egg' (and everything under it)
Processing pip-1.4.1-py2.7.egg removing
'/Users/dl/Library/Python/2.7/lib/python/site-packages/pip-1.4.1-py2.7.egg'
(and everything under it) creating
/Users/dl/Library/Python/2.7/lib/python/site-packages/pip-1.4.1-py2.7.egg
Extracting pip-1.4.1-py2.7.egg to
/Users/dl/Library/Python/2.7/lib/python/site-packages pip 1.4.1 is
already the active version in easy-install.pth Installing pip script
to /Users/dl/Library/Python/2.7/bin Installing pip-2.7 script to
/Users/dl/Library/Python/2.7/bin

Installed
/Users/dl/Library/Python/2.7/lib/python/site-packages/pip-1.4.1-py2.7.egg
Processing dependencies for pip==1.4.1 Finished processing
dependencies for pip==1.4.1

Entonces ingresé pip installel mensaje de error se mostraba así

Traceback (most recent call last):   File
"/Library/Frameworks/Python.framework/Versions/2.7/bin/pip", line 9,
in <module>
load_entry_point('pip==1.4.1', 'console_scripts', 'pip')()   File "build/bdist.macosx-10.6-intel/egg/pkg_resources.py", line 357, in
load_entry_point   File
"build/bdist.macosx-10.6-intel/egg/pkg_resources.py", line 2394, in
load_entry_point   File
"build/bdist.macosx-10.6-intel/egg/pkg_resources.py", line 2108, in
load ImportError: No module named pip

¿Alguien que haya tenido el mismo problema antes y pueda darme algunos consejos para solucionarlo?

  • Qué sucede cuando ejecuta pip install desde la terminal (no desde el intérprete de python)

    – Teórico

    21 de agosto de 2013 a las 17:16

  • El terminal muestra un error como “Error de importación: ningún módulo llamado pip”

    – David Lu

    24 de agosto de 2013 a las 10:24

  • Tengo la misma pregunta después de actualizar MacOSX. finalmente descubrí que la configuración de pip falló. Vuelva a instalar pip y luego arréglelo.

    – Boll Mose

    15 de diciembre de 2013 a las 10:59

  • puede consultar stackoverflow.com/questions/10061039/…

    – Jichao

    25 de febrero de 2015 a las 14:37

  • Parece que no será una solución para usted, pero siempre pruebo este comando cuando tengo problemas con pip. python -m pip install <package>

    – Martín P

    14/06/2016 a las 22:51

Yo tuve el mismo problema. Mi solución:

Para pitón 3

sudo apt-get install python3-pip

Para pitón 2

sudo apt-get install python-pip

  • la pregunta es sobre la instalación en Mac.

    –Corey Goldberg

    25 de mayo de 2017 a las 2:14

  • En Arch tuve que instalar python2-pip, python-pip apuntaba a python3

    – Florian Brinker

    12 de marzo de 2018 a las 14:45

  • ¡Dios mío, gracias! Tengo un cuadro vagabundo con python 3 y me preguntaba por qué los comandos pip no funcionaban cuando instalé pip a través de ‘sudo apt-get install python-pip’. Estos cambios de versión (es decir, como php con homebrew) me vuelven loco a veces…

    -Ryan Coolwebs

    12 de diciembre de 2018 a las 2:58

  • sudo yum install -y python38-pip ¡trabajó! Gracias..

    – Karthik Kumar

    16 de noviembre de 2021 a las 8:42

  • Package python-pip is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: python3-pip E: Package 'python-pip' has no installation candidate y E: Unable to locate package python2-pip por sugerencia de Florian

    – Draco P

    22 de febrero a las 3:21

avatar de usuario
iosCurator

En Mac usando elaborar cerveza es una mejor opción como apt-get no está disponible. Dominio:

brew install python

En caso de que tenga python2 y python3 instalados en la máquina

python2.7 -m ensurepip --default-pip

simplemente debería resolver el problema.

Si, en cambio, le falta pip de python 3, simplemente cambie python2.7 a python3 en el comando de arriba.

  • ¡Oh, finalmente una solución funcional! ¡Gracias! Necesitaba python3 en Mac (Mac OS X 10.13.4). Después de instalar python con Elaborar cerveza brew install python la pepita no fue encontrado: python3 -m pip install redis resultó en pip no encontrado. Siguiendo su enfoque (python3 -m …) funcionó.

    – Raípe

    17 de mayo de 2018 a las 5:13

  • Tengo python2 y 3 en la misma máquina, pero por ahora quería usar Python3. Por lo tanto, tuve que modificar el comentario anterior para sudo python3 -m pip install matplotlib (Tuve que hacer esto a través de sudo, de lo contrario, algunos permisos de carpeta no funcionaron). (editó la respuesta correspondientemente)

    – SCBuergel

    5 de enero de 2019 a las 7:55


  • Esto funcionó para mí, solo recuerda agregar un sudo al principio.

    – vauxhall

    7 de enero de 2021 a las 9:59

  • Cuando ejecuto el segundo comando, aparece: “zipimport.ZipImportError: no se pueden descomprimir los datos; zlib no está disponible”

    – Nermín

    10 de marzo de 2021 a las 7:14

Con macOS 10.15 y Homebrew 2.1.6 recibí este error con Python 3.7. Solo necesitaba ejecutar:

python3 -m ensurepip

Ahora python3 -m pip funciona para mi.

  • En Ubuntu obtengo “ensurepip está deshabilitado en Debian/Ubuntu para el sistema python”. resolví con sudo apt install python3-pip

    – tuxErrante

    18 de noviembre de 2019 a las 13:56

  • ¡Funciona también bajo Windows! Después de decir pip install --upgrade pip mi pip se había ido (porque pip se desinstaló con éxito pero no se pudo reinstalar porque pip.exe estaba ocupado…). python -m ensurepip trajo de vuelta el pip predeterminado, desde donde podía tomar la ruta de actualización correcta python -m pip install --upgrade pip

    – Adrián W.

    30 de noviembre de 2020 a las 22:49

  • Muchas gracias, esto me ayudó a solucionar este problema en WIndows sin reinstalar Python.

    – Maksim Shcherban

    18 oct 2021 a las 20:24

  • El comando de trabajo para mí en Windows fue python -m ensurepip

    – Daniel

    29 oct 2021 a las 19:10

  • FUNCIONÓ PARA WINDOWS!!! gracias hermano1

    – DANIEL ROSAS PÉREZ

    31 de diciembre de 2021 a las 20:59

Después de instalar ez_setupDeberías easy_install disponible. Instalar pip solo haz:

easy_install pip

para ventanas:

python -m ensurepip

después de activar su env ex: venv

(venv) PS D:\your path> d:\your path\venv\scripts\python.exe -m pip install --upgrade pip

muestra de resultado:

Pipa colectora

Uso de pip-21.3-py3-none-any.whl en caché (1,7 MB)

Instalación de paquetes recopilados: pip

Intentando desinstalar: pip

Found existing installation: pip 20.1.1

Uninstalling pip-20.1.1:

  Successfully uninstalled pip-20.1.1

Pip-21.3 instalado con éxito

avatar de usuario
alberto

Intenta instalar pip a través de Python:

Vaya a: https://pip.pypa.io/es/estable/instalacion/

y descargar get-pip.pyy luego ejecuta:

(sudo) python get-pip.py

avatar de usuario
Todo es amor

Correr

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py

Luego ejecute el siguiente comando en la carpeta donde descargó: get-pip.py

python get-pip.py

¿Ha sido útil esta solución?

Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Configurar y más información
Privacidad