¿Cómo hacer que Webpack, WordPress y BrowserSync funcionen juntos?

5 minutos de lectura

He estado en eso durante aproximadamente una semana y no he podido hacer que los tres trabajen juntos. Estaré eternamente agradecido si alguien me puede ayudar con esto, he perdido tantas horas.

La cuestión:

Si hago proxy de myserver.dev, recarga en caliente 404s. Cambiar publicPath no hace nada. Adjunto la URL a webpack-hot-middleware/client, corrige la ruta, pero el archivo hmr termina teniendo un error “GET” en la consola sin información. La recarga en caliente funciona bien si mantengo HTML y descarto cualquier php/MAMP. En general, estoy realmente confundido y probablemente me estoy perdiendo un concepto simple.

Lo que estoy tratando de llegar a trabajar juntos:

– WordPress por su API REST
– Reaccionar para vistas y ui
– MAMP para servidor local y MySQL
– BrowserSync para realizar pruebas en todos los dispositivos
– Webpack para compilar y recargar en caliente

Este es el repetitivo que usé:
https://github.com/Browsersync/recipes/tree/master/recipes/webpack.react-hot-loader

Estructura del directorio de temas:

-/Cía
-/origen
–/componentes
–/contenedores
–/estilos
–app.js
-paquete.js

-funciones.php

-index.php

-paquete.json
-servidor.js
-estilo.css

-webpack.config.js

Probé un millón de configuraciones, así que eliminé el código a continuación por simplicidad.

webpack.config.js:

var webpack = require('webpack');
var path = require('path');

module.exports = {
  context: path.join(__dirname, 'src'),

  entry: [
    'webpack/hot/dev-server',
    'webpack-hot-middleware/client',
    './app'
  ],

  output: {
    path: __dirname,
    publicPath: __dirname,
    filename: 'bundle.js'
  },

  plugins: [
    new webpack.optimize.OccurenceOrderPlugin(),
    new webpack.HotModuleReplacementPlugin(),
    new webpack.NoErrorsPlugin()
  ],

  module: {
    loaders: [
      { test: /\.jsx?$/, exclude: /node_modules/, loaders: ['react-hot', 'babel'] }
    ]
  }
};

servidor.js:

/**
 * Require Browsersync along with webpack and middleware for it
 */
var browserSync = require('browser-sync');
var webpack = require('webpack');
var webpackDevMiddleware = require('webpack-dev-middleware');
var webpackHotMiddleware = require('webpack-hot-middleware');

/**
 * Require ./webpack.config.js and make a bundler from it
 */
var webpackConfig = require('./webpack.config');
var bundler = webpack(webpackConfig);

/**
 * Run Browsersync and use middleware for Hot Module Replacement
 */
browserSync({
    proxy: {
      target: 'http://myserver.dev',
      middleware: [
        webpackDevMiddleware(bundler, {
          // IMPORTANT: dev middleware can't access config, so we should
          // provide publicPath by ourselves
          publicPath: webpackConfig.output.publicPath,

          // pretty colored output
          stats: { colors: true }

          // for other settings see
          // http://webpack.github.io/docs/webpack-dev-middleware.html
        }),

        // bundler should be the same as above
        webpackHotMiddleware(bundler)
      ]
    },

    // prevent opening a new window.
    open: false,

    // no need to watch '*.js' here, webpack will take care of it for us,
    // including full page reloads if HMR won't work
    files: [

    ]
});

paquete.json:

{
  "main": "server.js",
  "scripts": {
    "build": "webpack",
    "start": "node ."
  },
  "dependencies": {
    "babel-core": "^5.8.9",
    "babel-loader": "^5.3.2",
    "browser-sync": "^2.8.0",
    "react": "^0.13.3",
    "react-hot-loader": "^1.2.8",
    "webpack": "^1.10.5",
    "webpack-dev-middleware": "^1.2.0",
    "webpack-hot-middleware": "^1.1.0"
  }
}

  • publicPath especifica la dirección URL pública de los archivos de salida cuando se hace referencia a ellos en un navegador. __dirname está mal aquí, debería ser algo como http://localhost:3000. ver documentos.

    – puntos

    20 de diciembre de 2016 a las 23:04

  • ¿Alguna vez resolviste esto?

    – Felipe

    26 de enero de 2017 a las 22:24

Es posible que las cosas hayan cambiado con la nueva versión de Webpack y BrowserSync para WordPress a mediados de 2018, pero tengo una Receta simple y moderna de Webpack y BrowserSync para WordPress que tiene recarga en vivo para JS, CSS, y PHP. Esto usa React, pero no es específico de una configuración de React, solo importa/exporta el módulo ES6.

Estructura de carpetas:

theme
⊢⊸ api
  ⊢⊸ models
  ⊢⊸ controllers
  ⊢⊸  index.php
⊢⊸ frontend
  ⊢⊸ src
    ⊢⊸ App.js
    ⊢⊸ App.css
    ⊢⊸ index.js
  ⊢⊸ .babelrc
  ⊢⊸ package.json
  ⊢⊸ postcss.config.js
  ⊢⊸ webpack.config.js
  ⊢⊸ yarn.lock
⊢⊸ main.js
⊢⊸ functions.php
⊢⊸ index.php
⊢⊸ style.css

Paquete.json:

"scripts": {
  "start": "webpack --mode development --watch",
  "build": "webpack --mode production"
},
"devDependencies": {
  "autoprefixer": "^8.5.0",
  "babel-core": "^6.26.3",
  "babel-loader": "^7.1.4",
  "babel-preset-env": "^1.7.0",
  "babel-preset-react": "^6.24.1",
  "browser-sync": "^2.24.4",
  "browser-sync-webpack-plugin": "^2.2.2",
  "css-loader": "^0.28.11",
  "extract-text-webpack-plugin": "^4.0.0-beta.0",
  "postcss-loader": "^2.1.5",
  "react": "^16.4.0",
  "react-dom": "^16.4.0",
  "style-loader": "^0.21.0",
  "webpack": "^4.8.3",
  "webpack-cli": "^2.1.3",
  "webpack-dev-server": "^3.1.4"
}

Webpack.config.json

const path = require('path');
const ExtractTextPlugin = require('extract-text-webpack-plugin');
const BrowserSyncPlugin = require('browser-sync-webpack-plugin');

module.exports = {
  entry: { main: './src/index.js' },
  output: {
    path: path.resolve(__dirname, './../'),
    filename: 'main.js'
  },
  devtool: 'inline-source-map',
  devServer: {
    openPage: '',
  },
  module: {
    rules: [
      {
        test: /\.js$/,
        exclude: /node_modules/,
        use: {
          loader: "babel-loader"
        }
      },
      {
        test: /\.css$/,
        use: ExtractTextPlugin.extract(
          {
            fallback: 'style-loader',
            use: ['css-loader', 'postcss-loader']
          }
        )
      }
    ]
  },
  plugins: [ 
    new ExtractTextPlugin({filename: 'style.css'}),
    new BrowserSyncPlugin({
      files: [
        './../',
        './../api/**/*.php',
        './../api/*.php',
        './', 
        '!./node_modules',
        '!./yarn-error.log',
        '!./package.json',
        '!./style.css.map',
        '!./app.js.map'
      ],
      reloadDelay: 0
    })
  ]
};

Postcss.config.js

module.exports = {
  plugins: [
    require('autoprefixer')
  ]
}

.babelrc

{
  "presets": ["env", "react"]
}

Otras recomendaciones incluyen más bonita en la confirmación previa (usando Lint-Staged y Husky) para el formato de código en todos los proyectos JS, según corresponda .gitignore uso donde corresponda aquí, y Constructor de ACF para desarrolladores de WP.

  • Hola. ¿Sabe cómo lograr una recarga en caliente con cambios de CSS con su configuración?

    – Chopnut

    26 de agosto de 2020 a las 10:14

  • @Chopnut Con esta configuración, CSS debería estar recargando en caliente desde el primer momento. Si 2 años de versiones han cambiado algo, un cambio que recomendaría hacer es agregar un *.css línea a su lista de files en el BrowserSyncPlugin

    – JLF

    28 de agosto de 2020 a las 15:35

Bueno, no es exactamente una respuesta bien elaborada, pero tengo una configuración de Webpack muy básica en mi Repetitivo de Gutenberg eso lo ayudará a comenzar con ESNext, React, Webpack en WordPress.

Revisar la Bloque #02 y es configuración.

Quería responderte esto con un enlace:
https://css-tricks.com/combine-webpack-gulp-4/

Este artículo repasa todo lo necesario para resolver el problema. Funciona muy bien para mí. Sí usa trago, pero simplemente podría quitarlo de la configuración y modificarlo un poco. Sin embargo, los conceptos básicos de la configuración están todos ahí.

¿Ha sido útil esta solución?