Como instalar wordpress con postgresql

2 minutos de lectura

avatar de usuario
Diestro

Soy novato en wordpress. acabo de instalar wordpress 4.2.2. Quiero instalar wordpress en heroku con postgresql. Antes de eso, trato de instalar wordpress con postgresql en mi localhost. yo sigo el Instalación de PG4WP pasos, pero aún así mi instalación de wordpress con la base de datos mysql no me da la opción de instalar con postgresql.

estoy usando WordPress 4.2.2 versión y para la base de datos que estoy usando postgresql 9.1

Puede que sea un poco tarde, pero las respuestas actuales son y fueron incorrectas. Es posible usar PostgreSQL, aunque oficialmente no es compatible y no se recomienda por varias razones: La documentación oficial dice que sería costoso realizarlo, ya que cada nueva versión de wordpress tendría que probarse con la otra base de datos. -finaliza y dado que muchos complementos también se basan en llamadas específicas de mysql, probablemente nunca será posible hacer que “todo” sea compatible con múltiples bases de datos. Fuente: https://codex.wordpress.org/Using_Alternative_Databases

Si aún desea utilizar wordpress con PostgreSQL, el mejor lugar para comenzar sería la documentación oficial de PostgreSQL. Dice que se necesita un complemento de wordpress llamado ‘PG4WP’ para que funcione. Fuente: https://wiki.postgresql.org/wiki/Wordpress

  • Actualmente no hay nada en el wiki de postgresql, excepto dos enlaces que ya están en la pregunta resp. en la primera parte de esta respuesta. El complemento PG2WP parece estar desactualizado.

    –TNT

    15 mayo 2017 a las 17:49

  • Se puede encontrar un complemento más reciente basado en el OP vinculado en wordpress.org/plugins/wppg

    – svarog

    8 de enero de 2018 a las 11:05

Tutorial:
https://medium.com/@shoaibhassan_/instalar-wordpress-con-postgresql-usando-apache-en-5-min-a26078d496fb

Repo utilizado en el tutorial:
https://github.com/kevinoid/postgresql-for-wordpress

=== PostgreSQL for WordPress (PG4WP) ===
Contributors: Hawk__ (http://www.hawkix.net/)
Requires at least: 2.9.2
Tested up to: 4.5.3
Stable tag: 1.3.1
License: GPLv2 or later

PostgreSQL for WordPress is a special 'plugin' enabling WordPress to be used with a PostgreSQL database.

¿Ha sido útil esta solución?