cURL error 60: certificado SSL p‌r‌o‌b‌l‌e‌m: el certificado aún no es válido (LEMP WordPress + PHP7)

1 minuto de lectura

El avatar de usuario del hombre Dude
el tipo hombre

Me mudé a PHP7 hoy, así como a Nginx 1.10. Tengo un problema en mi backend de WordPress.

La prueba de la función de WordPress wp_remote_get() falló. Parece que su servidor no es totalmente compatible con WordPress. Póngase en contacto con su proveedor de alojamiento. Error: cURL error 60: problema con el certificado SSL: el certificado aún no es válido

He estado leyendo resoluciones para esto desde hace bastante tiempo. He descargado el paquete de CA de https://curl.haxx.se/ca/cacert.pem modificó el php.ini.

curl.cainfo = /etc/ssl/certs/cacert.pem

¿Necesito agregar el paquete a un paquete existente? ¿Necesito modificar los permisos en cacert.pem?

El problema está ocurriendo en la página de importación de datos de muestra. Estoy usando Lets Encrypt SSL.

  • ¿La fecha/hora de su servidor es correcta?

    – ceejayoz

    11/01/2017 a las 18:35

  • ¡GRACIAS ceejayoz! Muchas gracias, estoy agradecido.

    – El hombre Dude

    11 de enero de 2017 a las 19:56

  • Me alegro de haber ayudado. Active NTP para que no se repita. 🙂

    – ceejayoz

    11 de enero de 2017 a las 19:59

  • ceejayoz me salvaste!

    – Vladria

    23 de marzo de 2017 a las 16:05

¿Ha sido útil esta solución?