Evitar error: Composer requiere la versión de PHP (WordPress)

1 minuto de lectura

avatar de usuario
Mantequilla de mosca

Estoy tratando de evitar recibir este error cuando intento usar algunas bibliotecas de Google Analytics instaladas a través del compositor;

Composer detectó problemas en su plataforma: Sus dependencias de Composer requieren una versión de PHP “>= 8.0.2”

Mi versión de PHP es 8.0.13 pero no quiero actualizar a la última versión (8.1.1) todavía porque estoy ejecutando algunos complementos en mi sitio de WordPress que no son compatibles con PHP 8.1.1.

he intentado usar "platform-check": false en mi composer.json pero no hizo nada. También intenté actualizar a PHP 8.1.1 pero obviamente los complementos se rompieron.

¿Alguna idea sobre cómo resolver / evitar esto?

Mi compositor.json:

{
    "name": "vendor/proj_name",
    "require": {
        "google/apiclient": "^2.0"
    },
    "platform-check": false
}

  • ¿Podría mostrar su json de compositor?

    – Dmitri

    16 dic 2021 a las 10:30


  • Si la versión de PHP que está utilizando para ejecutar Composer realmente sería 8.0.13, dudo que Composer le diga lo contrario. Que hace composer diagnose decirte acerca de la versión de PHP?

    –Nico Haase

    16 de diciembre de 2021 a las 11:08


  • Correr composer diagnose devuelve 8.0.13

    – Mantequilla de mosca

    17 de diciembre de 2021 a las 3:22

  • Composer.json contenidos agregados arriba

    – Mantequilla de mosca

    17 de diciembre de 2021 a las 3:25


  • Tuve exactamente el mismo problema. Tenía instalado php7.4 y php8.0 y, no sé por qué, pero mi composer install funcionó correctamente y cuando inicié mi aplicación tuve el mismo error que tú. Acabo de eliminar php7.4 y luego funcionó.

    – Zahorí

    17 ene a las 15:47

¿Ha sido útil esta solución?

Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Configurar y más información
Privacidad