¿Habilitar/instalar la extensión GD? –sin-gd

2 minutos de lectura

avatar de usuario
shu

¿Cómo se habilita (o tal vez necesito instalar) GD cuando mi salida phpinfo () en “Configurar comando” dice; –sin-gd ?

Tampoco tengo nada en mi salida phpinfo() “Core” que enumere “gd”

PHP Versión 5.2.4 en AWS.

  • Tengo el mismo problema, pero me gustaría recordar que la pregunta no es cómo configurar gd en la terminal o cómo reiniciar su servidor. Después de todo, la pregunta es si no puede ver en el archivo phpinfo soporte de gd, ¿qué debe hacer? una de respuesta en php.net ingrese la descripción del enlace aquí dice que debe configurar su php –with-gd=”la ruta de su directorio a gd”

    – Víctor

    12 de septiembre de 2017 a las 8:58

avatar de usuario
Sebastián Viereck

Para uso PHP7.0 (php7.1-gd, php7.2-gd, php7.3-gd y php7.4-gd también están disponibles):

sudo apt-get install php7.0-gd

y luego reinicie su servidor web.

Para PHP8 usar:

sudo apt-get install php8.0-gd

avatar de usuario
Vindesh Mohariya

En mi caso (php 5.6, Ubuntu 14.04) el siguiente comando funcionó para mí:

sudo apt-get install php5.6-gd

De acuerdo con la versión de php, necesitamos cambiar el php5.x-gd

avatar de usuario
Mogsdad

Compruebe si en su archivo php.ini tiene la siguiente línea:

;extension=php_gd2.dll

si existe, cámbielo a

extension=php_gd2.dll

y reiniciar apache

(funciona en MAC)

avatar de usuario
galoget

Todas las respuestas anteriores son correctas pero no fueron suficientes para mí en ArchLinux. tambien necesitaba editar /etc/php/php.ini y para descomentar:

;extension=gd.so 

La inicial ; en la línea necesita ser eliminado. Después de reiniciar Nginx a través de systemctl restart nginxYo estaba bien para ir.

  • Bonito, 2019 aquí en arch, había instalado la extensión GD con yay -S php-gd pero eso no configuró php.ini/conf.d/gd.ini como debería. Tu consejo funcionó. El AUR probablemente necesita que su archivo de compilación se actualice para hacer eso. 3 minutos más tarde… oh, ese paquete ha sido marcado como desactualizado, parece php70-gd es el uno.

    – Elías Lynn

    31 de julio de 2019 a las 7:06

  • Para php 7.3, abra php.ini y ucommente extension=gd2

    – MattJamison

    30 de junio de 2021 a las 21:08

¿Ha sido útil esta solución?

Esta web utiliza cookies propias y de terceros para su correcto funcionamiento y para fines analíticos y para mostrarte publicidad relacionada con sus preferencias en base a un perfil elaborado a partir de tus hábitos de navegación. Al hacer clic en el botón Aceptar, acepta el uso de estas tecnologías y el procesamiento de tus datos para estos propósitos. Configurar y más información
Privacidad